erros "de montagem ./sbt/sbt" 'Não é um comando válido: montagem' para o projeto de faísca Apache

votos
49

Estou tendo problemas com a instalação de Apache faísca no Ubuntu 13.04. Im usando faísca-0.8.1-incubação, e ambos ./sbt/sbt updatee ./sbt/sbt compilefuncionar bem. No entanto, quando eu faço um ./sbt/sbt assemblyeu recebo o seguinte erro:

[info] Set current project to default-289e76 (in build  file:/node-insights/server/lib/spark-0.8.1-incubating/sbt/)   
[error] Not a valid command: assembly   
[error] Not a valid project ID: assembly   
[error] Not a valid configuration: assembly   
[error] Not a valid key: assembly   
[error] assembly   
[error]            

Eu pesquisei para o material relacionado a este mas não conseguiu encontrar nada de útil. Qualquer orientação seria muito apreciado.

Publicado 20/01/2014 em 20:41
fonte usuário
Em outras línguas...                            


2 respostas

votos
4

Você digitou "abt" duas vezes, mas não deve que ser "sbt"? Apache faísca tem a sua própria cópia do sbt, para se certificar que você está executando a versão de faísca para pegar o plugin "assembléia", entre outras personalizações.

Para executar a instalação Spark of sbt, vá para o diretório faísca e correr ./sbt/sbt assembly.

Respondeu 20/01/2014 em 21:39
fonte usuário

votos
5

A current project set to default-289e76mensagem sugere que sbtfoi chamado de fora do diretório de fontes de ignição:

$  /tmp  ./spark-0.8.1-incubating/sbt/sbt assembly
[info] Loading global plugins from /Users/joshrosen/.dotfiles/.sbt/plugins/project
[info] Loading global plugins from /Users/joshrosen/.dotfiles/.sbt/plugins
[info] Set current project to default-d0f036 (in build file:/private/tmp/)
[error] Not a valid command: assembly
[error] Not a valid project ID: assembly
[error] Not a valid configuration: assembly
[error] Not a valid key: assembly
[error] assembly
[error]         ^

Correndo ./sbt/sbt assemblyfunciona bem a partir do spark-0.8.1-incubatingdiretório (observe a saída do log mostrando que o projeto atual foi definido corretamente):

$  spark-0.8.1-incubating  sbt/sbt assembly
[info] Loading global plugins from /Users/joshrosen/.dotfiles/.sbt/plugins/project
[info] Loading global plugins from /Users/joshrosen/.dotfiles/.sbt/plugins
[info] Loading project definition from /private/tmp/spark-0.8.1-incubating/project/project
[info] Loading project definition from /private/tmp/spark-0.8.1-incubating/project
[info] Set current project to root (in build file:/private/tmp/spark-0.8.1-incubating/)
...
Respondeu 20/01/2014 em 22:11
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more