bibliotecas com.android.support deve usar exatamente a mesma versão de especificação e [] tendo problemas com os serviços do Google Play

votos
0

Eu estou tentando usar o preenchimento automático do Google placesApi e distância / mapas da API do Google Maps. Eu correr em um problema de compatibilidade quando eu adiciono tanto aos meus dependências (versão 26.1.0 para lugares). No entanto, quando eu tentei corrigi-lo por implementar cardview para 27.1.1, o mapa não mostra mais, e diz My App está tendo problemas com os serviços do Google Play.

Minha dependência é como segue:

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:27.1.1'

    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    implementation 'com.google.android.gms:play-services-maps:10.0.1'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
    implementation 'com.android.support:design:27.1.1'

    // 1. So far, Google Maps work


    // 2. After adding the following code --> Compatibility issue (27.1.1 vs 26.1.0)
    //implementation 'com.google.android.libraries.places:places-compat:1.1.0'    


    // 3. After adding the following code upfront --> My app having trouble with Google Play services
    //implementation 'com.android.support:cardview-v7:27.1.1'

}


Could someone give me some insights on how I may fix this problem?
Thanks!

Publicado 13/02/2020 em 23:59
fonte usuário
Em outras línguas...                            

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more