Escrevendo problemas de permissões com os seguintes diretórios / diretório de arquivos Elementor uploads

votos
0

Toda vez que eu quiser atualizar uma página específica no meu site wordpress a página fica congelado e não me deixar usar o construtor. Em Wordpress Painel I ver esta mensagem: Escrevendo problemas de permissões com os seguintes diretórios / diretório de arquivos Elementor uploads.

Quando eu verificar os logs de erros i encontrar o seguinte:

`[error] 14605#14605: *52603 FastCGI sent in stderr: PHP message: PHP Warning:
  file_put_contents(/var/www/corvettes2.performancecorvettes.com/public/wp-content/uploads/elementor/css/post-701.css): 
failed to open stream: 
Permission denied in /var/www/corvettes2.performancecorvettes.com/public/
wp-content/plugins/elementor/core/files/base.php` 

O que eu tentei até agora:

  1. Eu certifique- i ter definido as permissões corretas em pastas e arquivos (755 pastas e subpastas, 644 arquivos)
  2. I modificar as max_input_vars para 1000 no htaccess arquivo
  3. Tenho verificar o conf nginx arquivo para ter certeza que nada é estranho (eu ainda não encontrar nada de errado):

;

 user  nginx;
 worker_processes  auto;
 worker_rlimit_nofile 20000;
 error_log  /var/log/nginx/error.log warn;
 pid        /var/run/nginx.pid;


  events {
  worker_connections  4096;
  multi_accept on;
  use epoll;
}


 http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] $request '
                  '$status $body_bytes_sent $http_referer '
                  '$http_user_agent $http_x_forwarded_for';

access_log  /var/log/nginx/access.log  main;

sendfile on;
tcp_nopush on;
tcp_nodelay on;

keepalive_requests 100000;
keepalive_timeout  5;
send_timeout 10;

gzip  on;
gzip_http_version 1.0;
gzip_comp_level 2;
gzip_proxied any;
gzip_vary off;
gzip_types text/plain text/css text/xml application/xml application/rss+xml application/atom+xml application/x-font-ttf application/font-woff application/vnd.ms-fontobject application/javascript application/json application/x-javascript application/x-httpd-php application/x-httpd-fastphp application/x-httpd-eruby image/svg+xml text/javascript text/mathml;
gzip_min_length  1000;
gzip_disable     MSIE [1-6]\.;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
client_max_body_size 20M;
}
Publicado 13/02/2020 em 22:06
fonte usuário
Em outras línguas...                            


1 respostas

votos
0

Verifique a propriedade do diretório de upload e é arquivos. O mais provável é que eles estão de propriedade do root ou outro usuário. Se assim for, use chmod para mudá-lo para o usuário nginx.

Respondeu 14/02/2020 em 00:31
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more